CTX205014
2015-12-30
1970-01-01
The newslog file will not be compressed and this will cause the Netscaler appliance to runs out of disk space (/var gets full). ...

Symptoms or Error

The newslog file will not be compressed and this will cause the Netscaler appliance to runs out of disk space (/var gets full).

Solution

Look for?? nslog.nextzip file in the /var/nslog and check if it is empty and does not have any number in it. For example below:

root@my-vpx# cd /var/nslog
root@my-vpx# more nslog.nextzip
root@my-vpx#

Notice the output of above command didn't display any output

If everything is fine we will see a output like below:

root@my-vpx# cd /var/nslog
root@my-vpx# more nslog.nextzip
64


If the nslog.nextzip is empty and does not have any number listed please do below to resolve the issue. nslog.nextzip file should not be empty.

1)?? Login from CLI to netscaler and go to shell prompt:
2)?? cd /var/nslog/
3)?? cat nslog.nextfile (Note the output number, which is used later. (Example 88))
4)?? cat nslog.nextzip
5)?? If nslog.nextzip do not have any number in it, then you need add two numbers less than the number in nslog.nextfile (Ex 88 – 2 = 86)
6)?? Echo 86 > nslog.nextzip
7)?? Wait for some time and then again check to see if the newnslog files are getting compressed or not.
8) Go to /var/nslog and confirm if the newnslog files are getting compressed now.

This should fix the issue. If not then please open a support case and get this investigated further.

Problem Cause

nslog.nextzip file in the /var/nslog is empty and does not have any number in it.

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