CTX117346
Access Gateway 10,Access Gateway 9.1 Enterprise Edition,Access Gateway 9.2 Enterprise Edition,Access Gateway 9.3 Enterprise Edition,NetScaler 10,NetScaler 8.0,NetScaler 8.1,NetScaler 9.0,NetScaler 9.1,NetScaler 9.2,NetScaler 9.2.e,NetScaler 9.3,NetScaler
Access Gateway 10,Access Gateway 9.1 Enterprise Edition,Access Gateway 9.2 Enterprise Edition,Access Gateway 9.3 Enterprise Edition,NetScaler 10,NetScaler 8.0,NetScaler 8.1,NetScaler 9.0,NetScaler 9.1,NetScaler 9.2,NetScaler 9.2.e,NetScaler 9.3,NetScaler
Article
2016-04-14
2014-10-09
When using a NetScaler appliance in Use Source IP (USIP) mode, the customer experienced slow response to the client requests.

Symptoms or Error

When using a NetScaler appliance in Use Source IP (USIP) mode, a slow response to the client requests is experienced. For example, out of 20 backend servers deployed for load balancing, five servers delayed the responses for the client requests. Additionally, these servers had requests in surge queues that were not processed.

Background

The USIP mode enables the NetScaler appliance to communicate with the backend servers by using the original Client IP address as the source IP address, as opposed to the Mapped IP (MIP) or Subnet IP (SNIP). This enables an application to identify the IP address of the client.

Solution

To verify and resolve the issue, complete the following steps:

  1. Run the following command to verify the load balancing virtual server statistics:
    stat lb vserver <vserver_name>

  2. Run the following command to verify that there are not many requests to the load balancing Virtual IP (VIP):
    stat service <service_name>
    The output of this command displays the connections in the surge queue for the IP addresses of the servers having?? issue.

  3. Analyze the network packet traces of the NetScaler appliance.?? The analysis of the traces indicates that the monitor probes for the IP address of the servers with the issue are not receiving any acknowledgement from many instances.

  4. Verify if USIP mode is enabled on the appliance.?? If it?? is?? enabled on the appliance, then it indicates an issue with the backend servers.

  5. Check the backend server to find?? if an incorrect default gateway is configured on the backend servers.
  6. To resolve the issue, update the default route on the backend servers to point to the NetScaler appliance as a default gateway.

If you want to enable the USIP mode on the NetScaler appliance, then the backend servers should always add the NetScaler IP (NSIP) address as the default gateway for the backend servers. If you want to configure the default router as a return path for the response, then?? enable the Direct Server Return (DSR) feature on the NetScaler appliance.


Problem Cause

The backend servers were responding to the source IP address because the customer had enabled the USIP mode on the appliance. Therefore, the default route did not point to the NetScaler appliance. The response from the servers was never sent to the client through the NetScaler appliance. Additionally, the route on the server was changed for the production network traffic. Therefore, the NetScaler appliance had multiple open connections to the backend servers. As these connections were not get replied on time, the connections started to collect in the surge queue.


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