CTX107181
Secure Gateway 3.0,Web Interface 4.2,Web Interface 4.5 for Presentation Server,Web Interface 4.6 for Presentation Server,Web Interface 5.0,Web Interface 5.1,Web Interface 5.2,Web Interface 5.3,Web Interface 5.4,Web Interface for Presentation Server 4.0
Secure Gateway 3.0,Web Interface 4.2,Web Interface 4.5 for Presentation Server,Web Interface 4.6 for Presentation Server,Web Interface 5.0,Web Interface 5.1,Web Interface 5.2,Web Interface 5.3,Web Interface 5.4,Web Interface for Presentation Server 4.0
Article
2012-05-03
2012-05-03
Error: An error has occurred while connecting to the requested resource.

Symptoms

Users can log on to Web Interface through Secure Gateway but when attempting to launch a connection the following error message is returned in the Message Center:

“Error: An error has occurred while connecting to the requested resource.”

Web Interface may report a similar error:

The resource you requested is no longer available from the servers or the specified user no longer has access to it.

When you try to right-click and save the launch.ica file to the desktop, the following error message appears:

“Internet Explorer cannot download …”

Web Interface may show an Event ID 0.

"Event Type: Error
Event Source: Web Interface at c:\inetpub\wwwroot\Citrix\
Event Category: None
Event ID: 0
Date:
Time: 2:10:48 PM
User: N/A
Computer: YourServerName
Description: The MetaFrame servers reported that they are too busy to launch the selected item. This was reported from the XML Service at address "YourFQDN/IPAddress". [Log ID: aa185a20]

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

- Or -

??

"Event Type: Error
Event Source: Web Interface at c:\inetpub\wwwroot\Citrix\
Event Category: None
Event ID: 0
Date:
Time: 1:40:49 PM
User: N/A
Computer: YourServerName
Description:
The MetaFrame servers reported that the alternate address cannot be found. This was reported from the XML Service at address "http://YourFQDN/IPAddress:XMLPort". [Log ID: 520de53a]

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

-Or-

Event Type: Error

Event Source: Web Interface at c:\inetpub\wwwroot\Citrix\

Event Category: None

Event ID: 0

Date:

Time: 7:32:21 PM

User: N/A

Computer: WI

Description:

The Citrix servers reported that they are too busy to launch the selected item. This was reported from the XML Service at address "http://10.x.x.x:81 [com.citrix.xml.NFuseProtocol.RequestAddress]". [Log ID: dcab9cbe]

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Cause 1

There is a syntax error in the Web Interface configuration under “Edit Secure Gateway Settings” for the STA address.

Cause 2

The Citrix XML broker service may have an unstable Citrix XML Service at the address specified in the Event Viewer Description field.

Cause 3

The server reaches full load and rejects any new connections.

Cause 4

One or more of the servers that publish applications do not have the alternate address defined.

Resolution 1

Adding the STA port to the Secure Ticket Authority URL resolves the problem:

http://servername:8080/scripts/CtxSTA.dll

The STA UID in the Secure Gateway Configuration may not match that of the actual configured STA. This can be reproduce in a single server farm environment by having a working Secure Gateway, Web Interface, and Presentation Server set-up and then changing the STA within the CTXSTA.config file and re-starting the IMA service on the XenApp Server. In this case, the customer had cloned the servers and then remembered to change the STA on the XenApp servers. They, however, forgot to re-run the Secure Gateway Configuration Wizard.

Resolution 2

Restart the Citrix XML Service on the address specified in the Event Viewer Description field.

CTX104063 – Explaining and Changing the Citrix XML Service Port

Resolution 3

Run the qfarm / load command to check the load status of the servers and change the load evaluator if needed.

CTX112082 – Troubleshooting Load Balancing Issues

Resolution 4

1. Open a command prompt on Presentation Server and run the altaddr command.

2. Make sure the alternate address is shown. If it is not shown, run the altaddr /set <AlternateIPAddress> command.

Citrix eDocs ALTADDR - /proddocs/topic/xenapp6-w2k8-admin/ps-commands-altaddr.html

More Information

CTX107406 – Server Cloning with Presentation Server 4.x and XenApp

CTX108361 – [Document Not Found]

CTX104974 – [Document Not Found]

CTX584485 – [Document Not Found]

CTX039746 – IMA and ICA Browsing With Firewall Address Translation (NAT)

CTX105313 – [Document Not Found]


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