CTX106683
XenApp
XenApp 6_5 for Windows Server 2008 R2,XenApp 6_0 for Windows Server 2008 R2,XenApp 5_0 for Windows Server 2008
Configuration
2016-04-15
2014-04-01
This article provides a resolution for the Event ID 1116: "Printer auto-creation failure. Reason: AddPrinter() failed with status 0x5".

Symptoms or Error

Client printers do not autocreate when connecting to XenApp Server 5.0 or later. The following event is written to the Application log:

Event ID: 1116
Source: MetaFrameEvents
Event Message: Printer auto-creation failure. Reason: AddPrinter() failed with status 0x5
The message contains information on which printer failed and there is a separate event for each client printer.
Converting hex 5 into decimal gives 5 and using net helpmsg provides the following information:??
“C:\Documents and Settings\Administrator.FTLRLAB>net helpmsg 5
Access is denied.”
Additionally, if you try to add the printers manually through the client network inside a session, the process fails with the following error:
“You do not have sufficient access to your computer to connect to the selected printer”


Solution

To resolve the issue, complete the following steps:

  1. In the Local Security Settings, under User Rights Assignment, add the local Ctx_CpsvcUser or Local Service account to the?? Load and unload device drivers?? policy.
    User-added image

  2. Restart the Citrix Print Manager Service for the change to take effect.


    Problem Cause

    The issue occurs because of the following causes:

    • In XenApp Server 5.0, the Ctx_CpsvcUser account might not have the correct rights.

    • In XenApp Server 6.x, the Local Service account might not have the correct rights.

    • The user needs to be assigned rights to load and unload device drivers on the server.


     

    Join the conversation

    Citrix Discussions

    Open a case

    Citrix Support

    特别说明


    本文来源为Citrix.com所有,翻译后版权归翻译者所有.如需转载请注明出处.

    文档版本


    .

    广告招租


    最新留言


    .

    广告招租


    .