現象
「エラー:26008 IMAサービスの起動時にエラーが発生しました。CTX_MF_IMA_StartIMAService Error = 1075 or 1068」というようなエラーが発生します。
原因
IPSECサービスまたは依存関係のあるサービスが起動されていません。
注:IPSecが使用されている場合は、Presentation ServerまたはXenAppはIPSECに依存します。
再現方法(Presentation Server 4.0、4.5、またはXenApp 5.0の場合):
1. Windows 2000 Service Pack 4、Windows Server 2003 Service Pack 1またはWindows Server 2008のサーバーを構築します。
2. Windows 2000の場合はIPSecポリシーエージェントサービスを、Windows 2003の場合はIPSecサービスを、Windows 2008の場合はIPsec ポリシーエージェントを停止してから、サービスを[無効]に設定します。
3. Presentation Server 4.0、4.5またはXenApp 5.0をストールします。
4. 上記のエラーメッセージが表示され、インストールに失敗します。
5. Windows 2000の場合はIPSecポリシーエージェントサービスを、Windows 2003の場合はIPSecサービスを、Windows 2008の場合はIPSecポリシーエージェントを[自動]に設定してから、サービスを再起動します。
6. 再度Presentation ServerまたはXenAppをインストールすると、正しくインストールされます。
解決方法
Citrix Presentation Server 4.0、Citrix Presentation Server 4.5またはXenApp 5.0のインストール前に、すべての必要なサービスが起動していることを確認します。必要なサービスは以下のとおりです。
• リモート プロシージャ コール(RPC)
• サーバー
• ワークステーション
• Windows Management Instrumentation (WMI)
• IPSec Service(Presentation Server 4.0、4.5またはXenApp 5.0)
注:この手順ではレジストリの編集が必要になります。レジストリエディタの使用を誤ると、深刻な問題が発生する可能性があり、Windowsの再インストールが必要になることがあります。レジストリエディタは自己の責任と判断の範囲でご使用ください。また、レジストリファイルのバックアップを作成してから、レジストリを編集してください。
IPSecサービスを有効に設定する必要がない場合は、インストールが正しく終了した後に、以下のレジストリキーを編集してIMAサービスへのIPSecの従属性を無効に設定します。
1. HKEY_LOCAL_MACHINESystemCurrentControlSetServicesIMAServiceDependOnService
2. 「PolicyAgent」の値を削除します。
3. サーバーを再起動した後、IMAに干渉することなくIPSecサービスを停止できるようになります。
関連情報
この資料は米国のCitrix Knowledge Baseで提供している情報をもとに作成したものです。
Document ID:101931
Error: 26008 Start IMA Service returned error in CTX_MF_IMA_STARTIMASERVICE 1075 or 1068