CTX101917
XenApp
XenApp 6_5 for Windows Server 2008 R2,XenApp 6_0 for Windows Server 2008 R2,XenApp 5_0 for Windows Server 2008
Performance
2015-09-11
2005-06-06
This article provides resolution to Error: "Windows could not start the Independent Management Architecture on Local Computer .. and refer to service ...

Symptoms or Error

When a domain or local user is configured, the IMA Service fails to start and the following error message appears:
“Windows could not start the Independent Management Architecture on Local Computer... Refer to service-specific error code –2147483647.”


Solution

To solve the issue, edit the following registry:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Add the local or domain user to the local Administrators group.

  2. When selecting the user account in the IMA Service Logon dialog box, ensure The account has been granted the Logon as a Service dialogue box appears. If it does not appear, manually grant the right to the user.

  3. Open Regedt32.exe and grant Full Control rights to the local Administrators group on the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\IMA\Data


    Problem Cause

    The domain or local user must have full control for several files and registry entries. Must also have Log On As A Service right on the local machine.


    Disclaimer

    Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

     

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